网络时代交流中心

 找回密码
 立即注册
搜索
热搜: 活动 交友 discuz
查看: 5135|回复: 6

Cisco 2950交换机基本配置命令

[复制链接]

281

主题

303

帖子

8万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
80889
发表于 2014-10-11 04:39:29 | 显示全部楼层 |阅读模式

Cisco 2950交换机基本配置命令

  1、设置交换机密码

  a、更改远程TELNNET密码

  Switch#configure terminal

  Switch(config)#line vty 0 4

  Switch(config-line)#password qycx123

  Switch(config-line)#login

  Switch(config-line)#exit

  b、更改进入全局配置模式时的密码

  Switch#configure terminal

  Switch(config)#enable secret qycx123

  2、创建并划分VLAN

  a、创建VLAN

  Switch#vlan database

  Switch(vlan)#vlan 99 name office

  (创建vlan 99 并命名为office)

  b、将端口划分至vlan

  Switch(config)#interface fastEthernet 0/8

  Switch(config-if)#switchport mode access

  Switch(config-if)#switchport access vlan 99

  (将8号快速以太口划分至vlan 99)

  3、常用调试命令

  a、显示所有配置命令:Switch#show run

  b、显示所有接口状态:Switch#show ip int brief

  c、显示所有VLAN的信息:Switch#show vlan brief

       switch>

  switch>enable

  switch#

  switch#vlan database(进入vlan维护模式)

  switch(vlan)#vlan 2 name vlan2(给vlan 2命名为vlan2)

  switch(vlan)#vlan 4 name vlan4(给vlan 4命名为vlan4)

  switch(vlan)#exit(这里要注意一下,要打入exit退出才有效,不能用ctrl+z或end直接退出,因为这么不能使配置生效!)

  switch#show vlan(查看vlan的配置,默认有vlan1)

  switch#configure terminal(进入全局配置模式)

  switch(config)#interface f0/1(进入fastethernet0/1接口配置模式)

  switch(config-if)#switchport mode access(这步可以省略)

  switch(config-if)#switchport access vlan 2(把该接口划分到vlan2,记得vlan2之间有空格)

  switch(config-if)#no shutdown(激活端口)

  switch(config-if)#exit

  switch(config)#interface f0/2

  switch(config-if)#switchport mode access

  switch(config-if)#switchport access vlan 4

  switch(config-if)#no shutdown

  switch(config-if)#exit

  switch(config)#interface f0/3

  switch(config-if)#switchport mode trunk(设置此口为中继模式)

  switch(config-if)#no shutdown

  witch(config-if)#exit(这里可以直接用ctrl+z或end直接退出到特权模式)

  二.在路由器Cisco2611上的配置(!!!单臂路由!!!)

  router#configure terminal

  router(config)#interface f0/0.1(进入子接口模式)

  router(config-subif)#encapsulation dot1q 2(设置封装类型为dot1q,它是思科特有的。此外还有isl封装,要看该设备支不支持。数字2是vlan号)

  router(config-subif)#ip address 192.168.1.1 255.255.255.0

  router(config-subif)#exit

  router(config)#interface f0/0.2

  router(config-subif)#encapsulation dot1q 4

  router(config-subif)#ip address 192.168.3.1 255.255.255.0

  router(config-subif)#exit

  router(config)#interface f0/0

  router(config-if)#no shutdown

  router(config-if)#^z

  router#show running-config

  router#copy running-config startup-config

  三.给PC1,PC2设置好IP地址,然后用ping命名令测试!

  --------------------------------------------------------------------------------------------------------

  1、配置IP地址

  交换机要能够被网管,必须给它标识一个管理IP地址,默认情况下CISCO交换机的VLAN 1为管理VLAN,为该VLAN配上IP 地址,交换机就可以被网管了。命令如下:

  a、进入全局模式: Switch#configure terminal

  b、进入VLAN 1接口模式:Switch(config)#interface vlan 1

  c、配置管理IP地址:Switch(config-if) # ip address [A.B.C.D] [mask]

  如果当前VLAN 不是管理VLAN ,只需要将上面第b处命令的vlan的号码换成管理VLAN的号码即可。

  2、打开SNMP协议

  a、进入全局模式: Switch#configure terminal

  b、配置只读的Community,产品默认的只读Community名为public

  Switch(config)#snmp-server community public ro

  c、配置可写的Community,产品默认的可写Community名为private

  Switch(config)#snmp-server community private rw

  3、更改SNMP的Community密码

  a、将设备分组,并使能支持的各种SNMP版本

  Switch(config)#snmp-server group qycx123 v1

  Switch(config)#snmp-server group qycx 123 v2c

  Switch(config)#snmp-server group qycx123 v3 noauth

  b、分别配置只读和可写community 如:

  Switch(config)#snmp-server community qycx123 ro

  Switch(config)#snmp-server community qycx123 rw

  4、保存交换机配置

  Switch#copy run start


回复

使用道具 举报

0

主题

3

帖子

8

积分

新手上路

Rank: 1

积分
8
发表于 2014-10-11 22:29:59 | 显示全部楼层
我初学cisco的ccna,多谢楼主提供的资料,希望楼主以后多贡献点资源哈
回复 支持 反对

使用道具 举报

281

主题

303

帖子

8万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
80889
 楼主| 发表于 2014-10-11 22:31:21 | 显示全部楼层
OK,没问题,新人就是要多多学习才能更快的掌握技术,加油
回复 支持 反对

使用道具 举报

1

主题

13

帖子

29

积分

新手上路

Rank: 1

积分
29
发表于 2014-10-11 23:08:47 | 显示全部楼层
CCNA  是没想法了  全英文啊     不过以后有问题还是会来问LZ的
回复 支持 反对

使用道具 举报

281

主题

303

帖子

8万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
80889
 楼主| 发表于 2014-10-11 23:11:25 | 显示全部楼层
459570961 发表于 2014-10-11 23:08
CCNA  是没想法了  全英文啊     不过以后有问题还是会来问LZ的

亲,不要放弃哦,其实多背背题库也没什么难的,我英语一样也好烂,也通过了ccna啊,主要是贵在坚持啊
回复 支持 反对

使用道具 举报

0

主题

8

帖子

28

积分

新手上路

Rank: 1

积分
28
发表于 2014-10-14 03:43:20 | 显示全部楼层
谢谢楼主分享的资料
回复 支持 反对

使用道具 举报

281

主题

303

帖子

8万

积分

管理员

Rank: 9Rank: 9Rank: 9

积分
80889
 楼主| 发表于 2014-10-14 03:47:01 | 显示全部楼层
qwer951123 发表于 2014-10-14 03:43
谢谢楼主分享的资料

多谢顶贴
回复 支持 反对

使用道具 举报

您需要登录后才可以回帖 登录 | 立即注册

本版积分规则

深圳市原创科技有限公司
快速回复 返回顶部 返回列表